Firmware 3.65 will become the new FW 3.60 and more!

Ever since firmware 3.61 was released back in August 2016 to prevent HENkaku from running, the most popular PSVita hacking request was support for a higher firmware. Yesterday, TheFlow has decided to put everybody’s mind at rest and tell us which firmware we should be on for a hack!

 

What is TheFlow’s hack all about?

If you were not in the loop, since last March you could update to FW 3.65 from 3.60 and still keep your hack (with the untether)

If you weren’t following, earlier this year, in February to be exact, TheFlow told us that he had a hack on his hand that supports FW 3.61+, including 3.67. Then, in March he released his CFW Updater which updated PSVita/PSTV consoles running 3.60 to a hacked version of 3.65 with HENkaku Ensō which let you run games that require a higher FW. After that, in April, he announced that Sony’s most recent PSV firmware, version 3.68, doesn’t break his previous hack so that means that the current latest FW will still be getting his upcoming hack!

 

Apart from telling us about his hack, TheFlow also told he plans to release towards the end of this year or next year so obviously the question on many people’s mind changed from “Is there a hack for FW 3.61+??” to “Which firmwares will be hackable?”. Thanks to yesterday’s tweet, TheFlow has properly answered this question as will be discussed in the following section.

So, which firmware should you be on after all?

Apparently FW 3.61 and 3.63 won’t be getting the hack so you can get off those firmwares if you want!

In the simplest way possible, this is which firmware your PSVita should be on if:

  • You are on firmware 1.03-3.57, you are safe to update to firmware 3.60 as that’s the only version where you can get HENkaku/taiHEN running right now!
  • You are on firmware 3.60, for now I personally advise staying there as you can play dumped copies of games that require 3.61-3.65 (albeit illegally) and run all your favourite homebrew/plugins.
    • If you really want to go to firmware 3.65, you can use TheFlow’s CFW updater and through that you’ll have HENkaku Ensō running on FW 3.65. Remember, the full exploit chain hasn’t been released so you can’t reinstall the OS and if you manage to mess up HENkaku Ensō, your PSVita will no longer be hacked!
  • If you’re on firmware 3.61 or 3.63 and don’t have ARK-2, you are free to update to firmware 3.65 since that will be supported by TheFlow’s upcoming hack and will also let you run HENkaku Ensō (HENkaku without having to apply it every reboot). DO NOT UPDATE TO FIRMWARE 3.67 OR 3.68 IF YOU’RE HERE AND ARE WAITING FOR A HACK.

    If you were losing sleeping on which FW you should have on your PSVita, TheFlow has come to the rescue!

  • If you’re on unhacked firmware 3.65, stay there! If you’re on firmware 3.65 hacked (through CFW Updater from 3.60), also stay there.
  • If you’re currently on firmware 3.67, you can update to firmware 3.68 if you want to as there are no real differences BUT do keep in mind that some homebrew/plugins that have been updated with FW 3.67 support might not work due to different memory offsets.

Finally, TheFlow also stated that his hack will only run on firmware 3.65-3.68 BUT the untether will only work on firmware 3.65 as FW 3.67-3.68 have patched the exploit in the bootloader that HENkaku Ensō was using! That means that HENkaku will have to be applied every reboot on FW 3.67 and 3.68 like we did before HENkaku Ensō was released last year.

Conclusion



Obviously, TheFlow telling us this information doesn’t mean that he’ll be releasing his hack any sooner so don’t go pestering him! Remember, TheFlow doesn’t owe you anything so he isn’t obliged to release anything and is doing this out of his own initiative.

TheFlow’s Twitter (further updates): https://twitter.com/theflow0

Donation link (it’s in the README itself. Yes, the email has the word Cinderella in it but TheFlow has confirmed that it’s legitimate 🙂 ): https://github.com/TheOfficialFloW/Adrenaline/blob/master/readme.md

Trả lời

Email của bạn sẽ không được hiển thị công khai. Các trường bắt buộc được đánh dấu *